SpringBoot项目连接MySQL数据库 5.x和8.x配置区别

avatar 2018年09月25日16:08:06 6 5413 views
博主分享免费Java教学视频,B站账号:Java刘哥
MySQL8.0发布也有好几年了,现在很多新人学习都是默认安装最新版的,而他的代码可能是从网上下载的,里面的数据库需要使用 5.x版本。 原因很简单,MySQL5.x和8.x不兼容,需要更新新的驱动jar包和数据库连接信息。

以下是 5.x的相关配置

1、驱动包版本 pom.xml
  1. <!-- mysql驱动,适用于 5.x版本-->
  2. <dependency>
  3.     <groupId>mysql</groupId>
  4.     <artifactId>mysql-connector-java</artifactId>
  5.     <version>5.1.29</version>
  6. </dependency>
  2、数据库连接信息 application.yml
  1. jdbc:mysql://localhost:3306/your_db?useSSL=false&useUnicode=true&characterEncoding=utf-8
 

以下是 8.x的相关配置

1、驱动包版本 pom.xml
  1. <dependency>
  2.     <groupId>mysql</groupId>
  3.     <artifactId>mysql-connector-java</artifactId>
  4.     <version>8.0.11</version>
  5. </dependency>
  2、数据库连接信息 application.yml
  1. jdbc:mysql://localhost:3306/your_db?useSSL=false&useUnicode=true&characterEncoding=utf8&serverTimezone=UTC
 
  • 微信
  • 交流学习,有偿服务
  • weinxin
  • 博客/Java交流群
  • 资源分享,问题解决,技术交流。群号:590480292
  • weinxin
avatar

发表评论

avatar 登录者:匿名
可以匿名评论或者登录后台评论,评论回复后会有邮件通知

  

已通过评论:0   待审核评论数:0